#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(```|`)(python)?\s*?\n?(from \S+ )?import \S+(\n.*?;)*\n((.*return \S+```)|(`return \S+`))"
Local $sString = "```import test```" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"```return test```" & @CRLF & _
"" & @CRLF & _
"`import test`" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"return test```" & @CRLF & _
"" & @CRLF & _
"`from test import test`" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"return test```" & @CRLF & _
"" & @CRLF & _
"import test" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"hello;" & @CRLF & _
"return test```" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")