import re
regex = re.compile(r"(```|`)(python)?\s*?\n?(from \S+ )?import \S+(\n.*?;)*\n((.*return \S+```)|(`return \S+`))", flags=re.MULTILINE)
test_str = ("```import test```\n"
"hello;\n"
"hello;\n"
"hello;\n"
"```return test```\n\n"
"`import test`\n"
"hello;\n"
"hello;\n"
"hello;\n"
"return test```\n\n"
"`from test import test`\n"
"hello;\n"
"hello;\n"
"hello;\n"
"return test```\n\n"
"import test\n"
"hello;\n"
"hello;\n"
"hello;\n"
"return test```\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")