re = /(```|`)(python)?\s*?\n?(from \S+ )?import \S+(\n.*?;)*\n((.*return \S+```)|(`return \S+`))/m
str = '```import test```
hello;
hello;
hello;
```return test```
`import test`
hello;
hello;
hello;
return test```
`from test import test`
hello;
hello;
hello;
return test```
import test
hello;
hello;
hello;
return test```
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end