package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(```|`)(python)?\s*?\n?(from \S+ )?import \S+(\n.*?;)*\n((.*return \S+```)|(`return \S+`))`)
var str = `\`\`\`import test\`\`\`
hello;
hello;
hello;
\`\`\`return test\`\`\`
\`import test\`
hello;
hello;
hello;
return test\`\`\`
\`from test import test\`
hello;
hello;
hello;
return test\`\`\`
import test
hello;
hello;
hello;
return test\`\`\`
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}