#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?Uis)\[url]https:\/\/(?:www\.)*+youtube\.com\/watch\?v=([\w\-]+)\[\/url\]"
Local $sString = "[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]"
Local $sSubst = "[media=youtube]\1[/media]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)