use strict;
my $str = '[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]';
my $regex = qr/\[url]https:\/\/(?:www\.)*+youtube\.com\/watch\?v=([\w\-]+)\[\/url\]/isp;
my $subst = '[media=youtube]\\1[/media]';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";