const regex = /\[url]https:\/\/(?:www\.)*+youtube\.com\/watch\?v=([\w\-]+)\[\/url\]/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[url]https:\\\/\\\/(?:www\\.)*+youtube\\.com\\\/watch\\?v=([\\w\\-]+)\\[\\\/url\\]', 'is')
const str = `[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]`;
const subst = `[media=youtube]\1[/media]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);