const regex = /(^[putdn])(_[a-zA-Z]+?[a-zA-Z0-9]*)(\.[a-zA-Z0-9]+)?(.Delta|.Snapshot|.Event)(D|W|M|BM|Q|Y)?(_v\d+.\d+)(_\d{4,8})?(_D\d+)(_[a-zA-Z]+[a-zA-Z0-9]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[putdn])(_[a-zA-Z]+?[a-zA-Z0-9]*)(\\.[a-zA-Z0-9]+)?(.Delta|.Snapshot|.Event)(D|W|M|BM|Q|Y)?(_v\\d+.\\d+)(_\\d{4,8})?(_D\\d+)(_[a-zA-Z]+[a-zA-Z0-9]*)', 'gm')
const str = `p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName
p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}