$re = '/(^[putdn])(_[a-zA-Z]+?[a-zA-Z0-9]*)(\.[a-zA-Z0-9]+)?(.Delta|.Snapshot|.Event)(D|W|M|BM|Q|Y)?(_v\d+.\d+)(_\d{4,8})?(_D\d+)(_[a-zA-Z]+[a-zA-Z0-9]*)/m';
$str = 'p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName
p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);