import re
regex = re.compile(r"(^[putdn])(_[a-zA-Z]+?[a-zA-Z0-9]*)(\.[a-zA-Z0-9]+)?(.Delta|.Snapshot|.Event)(D|W|M|BM|Q|Y)?(_v\d+.\d+)(_\d{4,8})?(_D\d+)(_[a-zA-Z]+[a-zA-Z0-9]*)", flags=re.MULTILINE)
test_str = ("p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip\n"
"p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip\n"
"p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName\n"
"p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip\n"
"p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip\n"
"p_SPEC.Delta_v13.0_20181110_D1.zip")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")