// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[putdn])(_[a-zA-Z]+?[a-zA-Z0-9]*)(\.[a-zA-Z0-9]+)?(.Delta|.Snapshot|.Event)(D|W|M|BM|Q|Y)?(_v\d+.\d+)(_\d{4,8})?(_D\d+)(_[a-zA-Z]+[a-zA-Z0-9]*)").unwrap();
let string = "p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName
p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1.zip";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}