#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![ \t]*///[ \t]*engineer).*[\r\n]+\s*((?:public|private).*)"
Local $sString = "using System;" & @CRLF & _
"using System.Collections.Generic;" & @CRLF & _
"using System.Linq;" & @CRLF & _
"using System.Text;" & @CRLF & _
"using System.Threading.Tasks;" & @CRLF & _
"" & @CRLF & _
"namespace ConsoleApplication7" & @CRLF & _
"{" & @CRLF & _
" /// <summary>" & @CRLF & _
" /// Blah blah" & @CRLF & _
" /// </summary>" & @CRLF & _
" /// engineer: blehbleh" & @CRLF & _
" public class Class1" & @CRLF & _
" {" & @CRLF & _
" /// <summary>" & @CRLF & _
" /// constructor" & @CRLF & _
" /// </summary>" & @CRLF & _
" /// engineer: mme" & @CRLF & _
" public Class1()" & @CRLF & _
" {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" /// <summary>" & @CRLF & _
" /// get data" & @CRLF & _
" /// </summary>" & @CRLF & _
" /// <param name="i">i param</param>" & @CRLF & _
" /// <returns>o param</returns>" & @CRLF & _
" public int GetData(int i)" & @CRLF & _
" {" & @CRLF & _
" return i;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")