import Foundation
let pattern = #"^(?![ \t]*///[ \t]*engineer).*[\r\n]+\s*((?:public|private).*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApplication7
{
/// <summary>
/// Blah blah
/// </summary>
/// engineer: blehbleh
public class Class1
{
/// <summary>
/// constructor
/// </summary>
/// engineer: mme
public Class1()
{
}
/// <summary>
/// get data
/// </summary>
/// <param name="i">i param</param>
/// <returns>o param</returns>
public int GetData(int i)
{
return i;
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)