re = /^(?![ \t]*\/\/\/[ \t]*engineer).*[\r\n]+\s*((?:public|private).*)/m
str = 'using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApplication7
{
/// <summary>
/// Blah blah
/// </summary>
/// engineer: blehbleh
public class Class1
{
/// <summary>
/// constructor
/// </summary>
/// engineer: mme
public Class1()
{
}
/// <summary>
/// get data
/// </summary>
/// <param name="i">i param</param>
/// <returns>o param</returns>
public int GetData(int i)
{
return i;
}
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end