using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![ \t]*///[ \t]*engineer).*[\r\n]+\s*((?:public|private).*)";
string input = @"using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApplication7
{
/// <summary>
/// Blah blah
/// </summary>
/// engineer: blehbleh
public class Class1
{
/// <summary>
/// constructor
/// </summary>
/// engineer: mme
public Class1()
{
}
/// <summary>
/// get data
/// </summary>
/// <param name=""i"">i param</param>
/// <returns>o param</returns>
public int GetData(int i)
{
return i;
}
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}