# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n\n(?:[^\n]|\n(?!\n))*BAD(?:[^\n]|\n(?!\n))*/\n\nGOOD/g;t' <<< "dfsdf
sdfdf
blablabla
blaBAD
bla
dsfsdf
sdfdf
foo bar BAD
"