re = /\n\n(?:[^\n]|\n(?!\n))*BAD(?:[^\n]|\n(?!\n))*/
str = 'dfsdf
sdfdf
blablabla
blaBAD
bla
dsfsdf
sdfdf
foo bar BAD
'
subst = '\\n\\nGOOD'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result