import re
regex = re.compile(r"\n\n(?:[^\n]|\n(?!\n))*BAD(?:[^\n]|\n(?!\n))*")
test_str = ("dfsdf\n"
"sdfdf\n\n"
"blablabla\n"
"blaBAD\n"
"bla\n\n"
"dsfsdf\n"
"sdfdf\n\n"
"foo bar BAD\n\n")
subst = "\\n\\nGOOD"
result = regex.sub(subst, test_str)
if result:
print(result)