$re = '/\n\n(?:[^\n]|\n(?!\n))*BAD(?:[^\n]|\n(?!\n))*/';
$str = 'dfsdf
sdfdf
blablabla
blaBAD
bla
dsfsdf
sdfdf
foo bar BAD
';
$subst = "\n\nGOOD";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;