# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bfoo\b|_foo_"
test_str = ("foo ---foo-- abc.foo.def 123(foo)456\n"
"_foo_ (_foo_)\n\n"
"foofooo foo_foo\n"
"___foo___\n\n"
"xxx_foo_zzzz xxxfoozzz\n"
"0000 foo_\n"
"9999 _foo...\n\n"
"foo_abc cba_foo\n\n"
"a foo_ _foo bar")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.