import Foundation
let pattern = #"\bfoo\b|_foo_"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo ---foo-- abc.foo.def 123(foo)456
_foo_ (_foo_)
foofooo foo_foo
___foo___
xxx_foo_zzzz xxxfoozzz
0000 foo_
9999 _foo...
foo_abc cba_foo
a foo_ _foo bar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)