re = /\bfoo\b|_foo_/
str = 'foo ---foo-- abc.foo.def 123(foo)456
_foo_ (_foo_)
foofooo foo_foo
___foo___
xxx_foo_zzzz xxxfoozzz
0000 foo_
9999 _foo...
foo_abc cba_foo
a foo_ _foo bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end