const regex = /[^\p{L}\s]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{L}\\s]+', 'gu')
const str = `Abc ÁØø;!+
And łęś....`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);