$re = '/[^\p{L}\s]+/u';
$str = 'Abc ÁØø;!+
And łęś....';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;