use strict;
my $str = 'Abc ÁØø;!+
And łęś....';
my $regex = qr/[^\p{L}\s]+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";