#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/firebasestorage\.googleapis\.com\/v0\/b\/uczsieapp\.appspot\.com\/o\/images%2F"
Local $sString = "https://firebasestorage.googleapis.com/v0/b/uczsieapp.appspot.com/o/images%2F50531a3b-826c-4f8d-a597-a419eab083f0?alt=media&token=dca85b39-e6e7-43ac-bfef-d098cb33c7d3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")