const regex = /https:\/\/firebasestorage\.googleapis\.com\/v0\/b\/uczsieapp\.appspot\.com\/o\/images%2F/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/firebasestorage\\.googleapis\\.com\\\/v0\\\/b\\\/uczsieapp\\.appspot\\.com\\\/o\\\/images%2F', 'gm')
const str = `https://firebasestorage.googleapis.com/v0/b/uczsieapp.appspot.com/o/images%2F50531a3b-826c-4f8d-a597-a419eab083f0?alt=media&token=dca85b39-e6e7-43ac-bfef-d098cb33c7d3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}