// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/firebasestorage\.googleapis\.com\/v0\/b\/uczsieapp\.appspot\.com\/o\/images%2F").unwrap();
let string = "https://firebasestorage.googleapis.com/v0/b/uczsieapp.appspot.com/o/images%2F50531a3b-826c-4f8d-a597-a419eab083f0?alt=media&token=dca85b39-e6e7-43ac-bfef-d098cb33c7d3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}