import re
regex = re.compile(r"<(ul|ol)>\s*<li>{([ .\w-]+)} *(.*?)<\/\1>", flags=re.MULTILINE | re.DOTALL)
test_str = ("\n"
"<ul>\n"
" <li>{ .class .asdf}some item</li>\n"
" <li>another</li>\n"
"</ul>\n\n"
"<ul>\n"
" <li>{.class} some item</li>\n"
" <li>another</li>\n"
"</ul>\n\n"
"<p>{.test}Content of the paragrap\n"
"</p>\n\n\n"
"<([a-z\\-]+)>{([ \\w\\.-]+)} *(.*?)<\\/\\1>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")