const regex = /(?<!Mathf.)(?<=\W)(Cos|Sin|Tan|Asin|Acos|Atan|Sgn|Sqr)(?=\W)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!Mathf.)(?<=\\W)(Cos|Sin|Tan|Asin|Acos|Atan|Sgn|Sqr)(?=\\W)', 'gm')
const str = ` alpha=(Mathf.Sin(GameTime/1.3f)+1.4f)/2
return Sgn Mathf.Sin(-90+Angle*-1);
Local float AC=v[1]*2 , float AB=v[0]*2 ,float BC=Sqr(AC^2 + AB^2);`;
const subst = `Mathf.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);