use strict;
my $str = ' alpha=(Mathf.Sin(GameTime/1.3f)+1.4f)/2
return Sgn Mathf.Sin(-90+Angle*-1);
Local float AC=v[1]*2 , float AB=v[0]*2 ,float BC=Sqr(AC^2 + AB^2);';
my $regex = qr/(?<!Mathf.)(?<=\W)(Cos|Sin|Tan|Asin|Acos|Atan|Sgn|Sqr)(?=\W)/mp;
my $subst = 'Mathf.$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";