using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"FirstName: (\w+), LastName: (\w+)";
string input = @"FirstName: John, LastName: Terry
FirstName: Bill, LastName: Clinton";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}