$re = '/FirstName: (\w+), LastName: (\w+)/m';
$str = 'FirstName: John, LastName: Terry
FirstName: Bill, LastName: Clinton';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);