package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)FirstName: (\w+), LastName: (\w+)`)
var str = `FirstName: John, LastName: Terry
FirstName: Bill, LastName: Clinton`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}