re = /FirstName: (\w+), LastName: (\w+)/m
str = 'FirstName: John, LastName: Terry
FirstName: Bill, LastName: Clinton'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end