using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]{3,4}[х ]+[0-9]{3,4}";
string input = @"1280х720
1280х720 (х кириллица)
1280 х 720
1280 х 720 (х кириллица)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}