package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{3,4}[х ]+[0-9]{3,4}`)
var str = `1280х720
1280х720 (х кириллица)
1280 х 720
1280 х 720 (х кириллица)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}