// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{3,4}[х ]+[0-9]{3,4}").unwrap();
let string = "1280х720
1280х720 (х кириллица)
1280 х 720
1280 х 720 (х кириллица)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}