package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<file>(?<subject>\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\d)?)(?<ext>\.\w{3,4})`)
var str = `0001_BL_EC.mat
1_BL_EC.mat
1231_NF_EO.mat
1231_NF_EO_1.mat
S0001_NF_EO_Matrix`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}