import re
regex = re.compile(r"(?<file>(?<subject>\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\d)?)(?<ext>\.\w{3,4})")
test_str = ("0001_BL_EC.mat \n"
"1_BL_EC.mat \n\n"
"1231_NF_EO.mat \n\n"
"1231_NF_EO_1.mat\n\n"
"S0001_NF_EO_Matrix")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")