const regex = /(?<file>(?<subject>\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\d)?)(?<ext>\.\w{3,4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<file>(?<subject>\\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\\d)?)(?<ext>\\.\\w{3,4})', 'g')
const str = `0001_BL_EC.mat
1_BL_EC.mat
1231_NF_EO.mat
1231_NF_EO_1.mat
S0001_NF_EO_Matrix`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}