import Foundation
let pattern = #"(?<file>(?<subject>\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\d)?)(?<ext>\.\w{3,4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0001_BL_EC.mat
1_BL_EC.mat
1231_NF_EO.mat
1231_NF_EO_1.mat
S0001_NF_EO_Matrix
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)