using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n((\d{4}\-\d{2}\-\d{2}))\s*(\n)(.+?)";
string input = @"
2018-12-04
sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf
dsfgdfh
dfsghgfhdfg
gfhgfhd
2018-12-03
cewe4fertger4y hrty wedsgse
gb
dfshfhd
hgfdh
dfsghdshd
2018-12-02
gffvdgsdhysd gfhfdfgcncfgh
f frhbn 5ryrthe54trbgf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}