$re = '/\n((\d{4}\-\d{2}\-\d{2}))\s*(\n)(.+?)/m';
$str = '
2018-12-04
sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf
dsfgdfh
dfsghgfhdfg
gfhgfhd
2018-12-03
cewe4fertger4y hrty wedsgse
gb
dfshfhd
hgfdh
dfsghdshd
2018-12-02
gffvdgsdhysd gfhfdfgcncfgh
f frhbn 5ryrthe54trbgf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);