use strict;
my $str = '
2018-12-04
sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf
dsfgdfh
dfsghgfhdfg
gfhgfhd
2018-12-03
cewe4fertger4y hrty wedsgse
gb
dfshfhd
hgfdh
dfsghdshd
2018-12-02
gffvdgsdhysd gfhfdfgcncfgh
f frhbn 5ryrthe54trbgf
';
my $regex = qr/\n((\d{4}\-\d{2}\-\d{2}))\s*(\n)(.+?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}