import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n((\\d{4}\\-\\d{2}\\-\\d{2}))\\s*(\\n)(.+?)";
final String string = "\n"
+ "2018-12-04\n"
+ "sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf\n"
+ "dsfgdfh\n"
+ "dfsghgfhdfg\n\n"
+ "gfhgfhd\n\n\n"
+ "2018-12-03\n"
+ "cewe4fertger4y hrty wedsgse\n"
+ "gb\n"
+ "dfshfhd\n"
+ "hgfdh\n\n"
+ "dfsghdshd\n\n\n"
+ "2018-12-02\n"
+ "gffvdgsdhysd gfhfdfgcncfgh\n"
+ "f frhbn 5ryrthe54trbgf \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}