const regex = /((\d{4}\-\d{2}\-\d{2}))(\n|.)*?(?=(\d{4}\-\d{2}\-\d{2}))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d{4}\\-\\d{2}\\-\\d{2}))(\\n|.)*?(?=(\\d{4}\\-\\d{2}\\-\\d{2}))', 'mg')
const str = `
2018-12-04
sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf
dsfgdfh
dfsghgfhdfg
gfhgfhd
2018-12-03
cewe4fertger4y hrty wedsgse
gb
dfshfhd
hgfdh
dfsghdshd
2018-12-02
gffvdgsdhysd gfhfdfgcncfgh
f frhbn 5ryrthe54trbgf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}