re = /((\d{4}\-\d{2}\-\d{2}))(\n|.)*?(?=(\d{4}\-\d{2}\-\d{2}))/m
str = '
2018-12-04
sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf
dsfgdfh
dfsghgfhdfg
gfhgfhd
2018-12-03
cewe4fertger4y hrty wedsgse
gb
dfshfhd
hgfdh
dfsghdshd
2018-12-02
gffvdgsdhysd gfhfdfgcncfgh
f frhbn 5ryrthe54trbgf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end