#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+(?:\.\d+)?).*?(\d+(?:\.\d+)?)"
Local $sString = ""Размер экрана": 4.5 - 5"" & @CRLF & _
""Размер экрана": 4.5 - 5.5"" & @CRLF & _
""Размер экрана": 100- 500.5""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")