package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+(?:\.\d+)?).*?(\d+(?:\.\d+)?)`)
var str = `"Размер экрана": 4.5 - 5"
"Размер экрана": 4.5 - 5.5"
"Разм ер экрана": 100- 500.5"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}